login issue 16-05-2013 Creator: Anonymous

Home Forums OpenPPM 2.0 Technical Suport (CLOSED – READ ONLY) login issue 16-05-2013 Creator: Anonymous

  • This topic contains 1 voice and has 0 replies.
Viewing 1 post (of 1 total)
  • Author
  • #3484



    I’m unable to login to OpenPPM with any of the default logins. Looking at catalina.log (seen from other topics around login in forum), I have following error reported :

    16 mai 2013 02:07:57 org.apache.catalina.realm.JAASRealm authenticate

    ATTENTION: Exception lors de l’authentification par login du nom d’utilisateur admin


    at es.sm2.openppm.auth.PlainLoginModule.login(PlainLoginModule.java:153)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at javax.security.auth.login.LoginContext.invoke(Unknown Source)

    at javax.security.auth.login.LoginContext.access$000(Unknown Source)

    at javax.security.auth.login.LoginContext$4.run(Unknown Source)

    at java.security.AccessController.doPrivileged(Native Method)

    at javax.security.auth.login.LoginContext.invokePriv(Unknown Source)

    at javax.security.auth.login.LoginContext.login(Unknown Source)

    at org.apache.catalina.realm.JAASRealm.authenticate(JAASRealm.java:409)

    at org.apache.catalina.realm.JAASRealm.authenticate(JAASRealm.java:334)

    at org.apache.catalina.authenticator.FormAuthenticator.authenticate(FormAuthenticator.java:261)

    at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:454)

    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)

    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)

    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)

    at org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:879)

    at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:617)

    at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1760)

    at java.lang.Thread.run(Unknown Source)

    Can you please help ?




    -Joan Barceló (16-05-2013)

    Hi Stephane,

    thanks for downloading and installing openppm.

    If you have installed Apache Tomcat as a windows service, you must configure the “jaas.config” in Apache Tomcat Properties dialog -> “Java” tab -> “Java Options” sections, and include the text:

    -Djava.security.auth.login.config=C:\Program Files\Apache Software Foundation\Tomcat 6.0\conf\jaas.config

    (check if your path is the same)

    Please, make sure that you have installed Tomcat 6.0.35.  You can download it  from: https://archive.apache.org/dist/tomcat/tomcat-6/v6.0.35/bin/

    Kind Regards!




    -Anonymous (20-05-2013)

    Hi Joan,

    I’ve not installed Tomcat as a service and ahd installed 6.0.37. Indeed switching to 6.0.35 made it for me.

    Thanks for your support !



    -Jan (14-08-2013)

    I do have the same exception, but not the possibility to change the tomcat properties that way (running it on ubuntu just with cli). Instead, I followed the Installation instructions and created the setenv.sh with the entry “JAVA_OPTS=-Djava.security.auth.login.config==$CATALINA_BASE/bin/jaas.config, but I still get that Java Exception. I also tried switching from tomcat 7 to tomcat 6.0.35, same exception.
    So what am I doing wrong?




    -Jan (15-08-2013)

    solved. I had no data in the db.




Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.