Login error with tomcat as windows service 17-01-2013 Creator: cebri

Home Forums OpenPPM 2.0 Technical Suport (CLOSED – READ ONLY) Login error with tomcat as windows service 17-01-2013 Creator: cebri

  • This topic contains 1 voice and has 0 replies.
Viewing 1 post (of 1 total)
  • Author
  • #3514


    I think is the same error. After install, if I run tomcat from startup.bat script it works fine. But if I install as windows service it doesn’t work.
    It seems like doesn’t find setenv.bat configuration. This lines from catalina log

    INFO: New Quartz update(s) found: 2.1.6
    ene 17, 2013 6:16:47 PM org.apache.catalina.realm.JAASRealm authenticate
    SEVERE: Unexpected error
    javax.security.auth.login.LoginException: No LoginModules configured for OpenPPMWeb
    at javax.security.auth.login.LoginContext.init(LoginContext.java:273)
    at javax.security.auth.login.LoginContext.<init>(LoginContext.java:418)
    at org.apache.catalina.realm.JAASRealm.authenticate(JAASRealm.java:393)
    at org.apache.catalina.realm.JAASRealm.authenticate(JAASRealm.java:334)
    at org.apache.catalina.authenticator.FormAuthenticator.authenticate(FormAuthenticator.java:260)
    at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:454)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
    at org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:879)
    at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:600)
    at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1703)
    at java.lang.Thread.run(Thread.java:722)

    Can you help me?



    -Daniel Casas (18-01-2013)


    if you prefer using the Tomcat as a windows service, you must configure the “jaas.config” in Apache Tomcat Properties dialog -> “Java” tab -> “Java Options” sections, and include the text:

    -Djava.security.auth.login.config=C:\Program Files\Apache Software Foundation\Tomcat 6.0\conf\jaas.config

    (chek if your path it’s the same)

    Please, try this and let us know if it works.




    -cebri (18-01-2014)


    Only for information, in services.msc doesn’t appear Java tab on Tomcat service properties. tomcat6w.exe on %CATALINA_HOME%\bin must be used.




    -jyike (10-06-2010)


    I had just manage to successfully installed OpenPPM unto a Windows machine by following the 13-Steps process/instructions. The Apache Tomcat now is manually started/run using the ‘startup.bat’. Since I used the Apache Tomcat 6 ZIP, it does not have the Tomcat6.exe file to install as a service.

    Can cebri or Daniel share how it can be done (start as a windows service)?

    [UPDATED: Hi guys, I realized I download the wrong Apache ZIP file which didn’t had the windows executable files. That has been rectified and have successfully installed as service and also updated the JAVA option as mentioned in Daniel’s post. ALL IS GOOD !]




Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.